Git with ssh cert not working ios 12 latest

#1

I cannot select my ssh cert files. Or I can but app keeps showing the default value “id_rsa” and “id_rsa.pub” instead of names of my files and fails to clone my repo. I do not plan to change to cleartext login on my git server, so please help. App is unusable if I cannot access my files.

0 Likes

#2

Hi Kleggas :wave:

Please ignore the name within those fields as that’s the name the files are renamed with when moving them onto the system keychain. Are you using the right passphrase? also, are you using the SSH address of the repository instead of the HTTPS one?

Thank you for your patience.

0 Likes

#3

Hi. How would that be done in play.js? When cloning on a computer I use “git clone domain:/repo” which does the job. I tried just adding domain:/repo, domain/repo, and also both https:// or ssh:// in front and it faile. Ofcourse, on the computer I have the user and certpath configured in ~/.ssh/config. I tried also adding user@ berofe domain (borh with ssh:// and without) but was just returned to the setup again and again.

The passphrase for the certs is correct, as is the user, I setup the repo (my server) and have cloned it to 5 different machines, so I know the user and passphrase needed.

0 Likes

#4

Hi again Kleggas,

Thanks for your quick reply.

The following setup works for me with one of my repositories.

As you can see the address is “git@github.com:nakiostudio/play.js-template-react.git”, leaving user and password fields empty.

0 Likes

#5

Seems to have been a case of PEBKAC, I had user both in user field and in url… it worked this time :slight_smile:

Thanx

1 Like

#6

Great! Sorry for the confusion, this is certainly an area for us to improve.

Thanks for reporting.

0 Likes