Could not clone from github, use ssh

Hello.

I Could not clone from github. (use ssh)

Below are the steps that I tried.

  1. Create ssh on my Macbook. ($ssh-keygen -t rsa)
  2. Sent id_rsa & id_rsa.pub to iPad mini4(iPad OS 13.1.2)
  3. Create a new project on play.js (with clone from git repository)
  4. Remote setting.
  • Address : git@github.com:XXX/project-name.git
  • User : Empty
  • Password: Empty
  1. SSH Setting.
  • Public Key : id_rsa.pub (created step1)
  • Private Key: id_rsa (created step1)
  • Passphrase: Entered passphrase.

Please let me know if I made a mistake.

Hi @takashicompany :wave:

Could you please try creating the ssh key with the following command?
ssh-keygen -t rsa -b 4096 -C "foo@bar.com" where foo@bar.com is the email address of your GitHub account?

Sorry for the inconvenience, I’ll try to improve the git logging.

Thanks for reply.

I tried creating ssh again with email address.

But not succeeded.

Is there anything else I can do?

Any updates? No logs are shown.

I’ve tried another application with the same private key, and I could clone github repo.

Hello,

I have the exact same problem, followed the same steps as @takashicompany and it just doesn’t work, I tried with both the ssh and https urls, but no luck. Being able to use github is essential to the work I’m doing… Is there any development on solving this?
Thanks!

Please accept my apologies because I know this answer comes very late.

Please generate the key pairs using the PEM format as follows:

ssh-keygen -t rsa -b 4096 -m PEM

play.js 2.0.0 will make dealing with Git more clear to avoid this kind of confusion.